DAS-BAHN-FORUM.de

Herzlich willkommen im ersten offiziellen Forum zum Programm BAHN von JBSS

Aktuelle Zeit: Montag 21. Juni 2021, 21:23

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Fehler ZGEN-BAPF
BeitragVerfasst: Freitag 29. Januar 2021, 10:43 
Offline

Registriert: Samstag 10. Dezember 2016, 16:01
Beiträge: 305
Wohnort: Stuttgart (ehemals bei Salzburg)
Guten Tag,

ich habe einen Fehler entdeckt, der mir aufgefallen ist, aber (meiner Erfahrung nach) die Simulation nicht beeinträchtigt.
Es geht um das Verschieben von Taktpunkten, wenn sich ein Fahrzeug darauf befindet.
Im konkreten Beispiel soll ein Taktpunkt mit darauf stehendem Bus (Fahrzeuglänge 1) verschoben werden.
Dateianhang:
Screenshot_20210129_102850.png

Wenn der Punkt, zu dem das Element verschoben werden soll und der Punkt, wo sich das Element jetzt befindet, im gleichen Fenster sichtbar sind (also nahe beieinander liegen), ist alles okay.
Ist der Punkt, von dem aus verschoben werden soll, nicht im Fenster sichtbar und man dann das verschieben ausführen will, kommt diese Meldung:
Dateianhang:
Screenshot_20210129_103037.png

Wenn ich diesen bestätige, passiert scheinbar nichts und das Feld, zu dem verschoben werden soll, bleibt leer. Jedoch ist auch das Element, das verschoben wurde, ist nicht mehr am "alten Platz" zu sehen.
Wenn man jedoch auf das leere Element, zu dem man verschoben hat, klickt, bekommt man aber die Richtigen Informationen, also im Beispiel sowohl Daten zum Taktpunkt als auch zum Fahrzeug.
Dateianhang:
Screenshot_20210129_103050.png


Das Element wird erst sichtbar, wenn man einmal raus und wieder reinzoomt. Dann ist alles okay und die Simulation läuft normal weiter.

Ich verwende Linux (Kubuntu 20.10) und BAHN 3.89r4a mit Wine. Das funktioniert ansonsten problemlos. Ich weiß nicht, ob das Problem nur unter Linux oder auch unter Windows auftritt.

Freundliche Grüße,
Hosea


Sie haben keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Fehler ZGEN-BAPF (2)
BeitragVerfasst: Freitag 29. Januar 2021, 15:56 
Offline

Registriert: Sonntag 16. März 2003, 15:25
Beiträge: 2130
Guten Tag,

S-Bahn-Freund Stgt hat geschrieben:
Guten Tag,

ich habe einen Fehler entdeckt, der mir aufgefallen ist, aber (meiner Erfahrung nach) die Simulation nicht beeinträchtigt.


Das ist richtig, d.h. es ist nur ein Problem der Anzeige im Normalmodus (also 1:1 oder größer).

S-Bahn-Freund Stgt hat geschrieben:
Es geht um das Verschieben von Taktpunkten, wenn sich ein Fahrzeug darauf befindet...


Es tritt beim Verschieben auf, wenn ein Zug aus dem nicht sichtbaren Bereich in den sichtbaren Bereich verschoben wird, also von außerhalb des Editfensters in dieses hinein. Ob da ein Taktpunkt ist, spielt keine Rolle.

S-Bahn-Freund Stgt hat geschrieben:
Das Element wird erst sichtbar, wenn man einmal raus und wieder reinzoomt.


..oder einmal in irgendeine Richtung um eine Seite blättert und wieder zurück.

S-Bahn-Freund Stgt hat geschrieben:
Dann ist alles okay und die Simulation läuft normal weiter.


Ja, es dürfte kein sonstiger Schaden entstehen.

S-Bahn-Freund Stgt hat geschrieben:
Ich verwende Linux (Kubuntu 20.10) und BAHN 3.89r4a mit Wine...


Das ist ein Problem von BAHN und müßte auf jedem Betriebssystem auftreten. Die Wahrscheinlichkeit ist umso größer, je kleiner das Fenster ist und je größer die Anzeige eingestellt ist. Wer einen kleinen Monitor hat und darauf M8:1 einstellt, wird öfter betroffen sein, aber gerade auf kleinen Bildschirmen nutzt man die höheren Auflösungen eher selten.

Danke für den Hinweis, an einer Lösung wird gearbeitet.

Freundliche Grüße,
Jan B.


Nach oben
 Profil  
Mit Zitat antworten  
 Betreff des Beitrags: Re: Fehler ZGEN-BAPF
BeitragVerfasst: Freitag 29. Januar 2021, 20:49 
Offline

Registriert: Samstag 10. Dezember 2016, 16:01
Beiträge: 305
Wohnort: Stuttgart (ehemals bei Salzburg)
Danke für die ausführliche Antwort und Erklärung!

Einen schönen Abend noch,
Hosea


Nach oben
 Profil  
Mit Zitat antworten  
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  

Bei allen Fragen zum Forum wenden Sie sich bitte an ronny@das-bahn-forum.de!

Unterstützen Sie das BAHN-Forum mit einer Bestellung bei Amazon.de!
Unterstützt durch phpBB
Version des BAHN-Forums: 4.5.1

Mit dem Lesen und Verfassen von Beiträgen akzeptieren Sie die Regelungen zur Nutzung des BAHN-Forums!